Presentation Software

Presentation Software allows you to present (normally) sequential information to assist with a presentation.

It allows you to include text, charts, graphics, etc., and program transitions between them.

- It’s based on the older practice of preparing film-based slides for slide shows in business meetings, conferences, etc.
  - i.e. actual photographic slides would be prepared in a photo lab to contain graphics, charts, etc.
- Good presentations should not contain all of the information itself, but rather cues for important points
- Today, the most powerful presentation software, by far, is Microsoft PowerPoint
Let’s Look at the Interface!

- Once again, as with the other Microsoft Office products, there’s a tool ribbon with familiar tab groups on it.
- By default, we see an overview of the slides on the left, and an enlarged view of a single slide in the main panel.
  - That slide view on the left can also be switched to an Outline view.
- Below the main view is an area for notes (more on this later).
- Under the View tab, we can also see additional options, such as ruler, gridlines, and guides.
- In the Show dialog box, we can enable things like snapping to the grid.
  - This is particularly important for slide shows, because visual layout is incredibly important.
  - It would be especially jarring if elements across slides were to appear to shift/jump during transitions.
- We might also be interested in the Slide Sorter, which provides us with a quick and easy way of looking over the entire presentation.
Slide Layout

- Note that the first slide is assumed to be a Title Slide.
- When adding a New Slide, you have the option of either creating a commonly-used “Title and Content” slide, or manually choosing a specific layout for the new slide.
- Similarly, you can change the **Layout** of the current slide by clicking on the Layout button.
Most of the prebuilt Slide Layouts include multiple *placeholders* for adding information. These include:

- A slide title (for text)
- Text panels (that by default will be treated as bulleted lists)
  - Note that you don’t *usually* have to manually resize text, as it should autoadjust for you
- Tables, charts, SmartArt, Pictures, Clip Art, or Media Clips

It is the number of said placeholders, and their relative layout/distribution that warrants the different slide options.
Shapes

Though these have already been available (in Word and Excel), shapes are of particular significance here, because it’s fairly common to need to illustrate things in presentations. You can find them on the Home tab.

- Note that, in addition to having numerous shapes available (including buttons, and arbitrary polygons), we can also control properties such as fill, outline, and effects (e.g. glowing)
  - There are also Quick Styles on the Home tab, if we’re interested

- Also note that, when we have multiple shapes on the same slide, we may have to start worrying about their relative depths
  - Even when only using a single shape, we can use this trick to place it behind the text!
Viewing Slide Shows

- To view the current slide show, from the beginning:
  - Press F5
  - Choose “From Beginning” on the *Slide Show* tab
- To view the current slide show, from the *current* slide:
  - Press Shift+F5
  - Choose “Frame Current Slide” on the *Slide Show* tab
  - Click the Slide Show icon in the lower-right corner
Themes

- Themes are essentially the same thing as they were in Word
- You can find them on the *Design* tab
Choosing different themes on the Design tab will apply the changes to all slides.

However, changing individual fonts/formatting for specific elements/positioning on a slide will not propagate.

- The correct way to make these changes is via the Slide Master
- A Master Slide is a prototype from which all slides are derived
  - Formatting, etc. are inherited from the master
  - Change the master, and you change every all of the other slides at once!
  - There's actually a hierarchical pattern here
    - The different layout prototypes are children of the master slide
    - You can create additional layouts in the same view
    - You can even create another master slide, if desired (though this isn't usually a fantastic idea)
Transitions

When you’re done viewing one slide, it’s typically adequate to simply display the next slide. However, sometimes you want to add a bit ‘extra’, to make the progression to the next piece of information ‘pop’ a bit. For this, we use transitions.

- Transitions simply indicate what animation (if any) should be used to introduce a new slide
- Some (though not all) transitions also have additional Effect Options
  - e.g. Being able to decide whether a ‘wipe’ is from the left, right, etc.
Advancing Slides

- By default, a slide is advanced on a click
  - Note that a press of the space bar, or pressing the right cursor key, may also be used, but this is considered a separate action
- Alternatively, you can choose to have your slide advance automatically (after some length of time), if you don’t wish to concern yourself with manually advancing
Animations are a bit of an unusual feature. They’re most commonly used in the same way as transitions, except for individual elements (text, shapes, etc.).

- An animation can simply control when an item appears (or disappears) from the slide
- It can control motion
- It can even follow an arbitrary path (a custom *Motion Path*)
- Animations may be tied together (e.g. two shapes can animate at the same time), or processed in sequence
- They may be triggered via the mouse, or time, or some combination of the two
Animations
Entrance, Emphasis, Exit

- Entrance animations cause an element to appear after the slide is displayed
  - They’re handy for when you wish to discuss a topic, present a possible problem/question, and then have an answer appear on the same slide

- Exit animations cause an element to disappear from the slide (but leaving everything else intact)
  - These don’t have a common use, outside of making space for something else to appear (e.g. for replacing one element with another)

- Emphasis animations are used for... emphasis
  - These may animate once, or may be told to repeat (even indefinitely)
  - Use these sparingly, as they may distract from what you’re discussing
Animations
Motion Paths

Motion Paths are simply a special case of animations wherein an element moves along some path.

- It may be used to control how an element is introduced to the screen
- It can be used for an interesting exit
- It can (but shouldn’t) be used to make something stand out
- It may be used to show progression (e.g. a packet travelling over the internet)

Custom motion paths let you create a bezier curve with an arbitrary number of points.
Animation Pane

The primary use of the Animation Pane is to see all animations currently present on the slide, and their relative sequences.

- It also makes it easier to coordinate things like effective reordering, and ensuring that group animations go together.
More advanced animations require more explicit control. The Effect Options... choice from the Animation Pane (not the Effect Options button... which is entirely different... sigh...) lets you choose things like how to start an animation, delays, repetition, how to animate text, triggers, and other advanced options advanced animations/timing/manual advancement/motion paths triggers

- Animating text may be done by letter, word, etc.
- Triggers are used for having an animation initiated by clicking on a specific element (which also may be an entirely different one)
Hyperlinks/Actions

Hyperlinks and Actions let you assign special functionality for when you click on elements hyperlinks/actions, including jumps to hidden slides:

- You can have it bring up a webpage
- It can jump directly to a specific slide (even a hidden slide)
- It can even link to a special object or another program
  - I’d advise against this; if someone’s presentation tried to start another program on me, I’d assume it was malicious
Annotation During Presentation

While making a presentation, the default pointer is the array (i.e. a normal cursor, good for advancing slides).

As an alternative, you can right-click the screen and choose to use a Pen, which will let you draw on the slide.

You can also choose a Highlighter for similar purposes.

After the presentation is over, you’ll have the option of saving your annotations.
Laser Pointer

One additional feature during presentation is the *Laser Pointer*. It’s simply designed to mimic the use of an actual laser pointer; allowing you to make things stand out while it’s activated.

It’s a feature of the arrow pointer that you can activate by holding down the Ctrl key.
Embedded Objects

If desired, audio, video, and other objects may be embedded into a presentation.

- Embedded media will be included with the presentation when you distribute it
- Of course, this means the presentation’s filesize will reflect that of the embedded media
- I’d suggest doing this very sparingly (particularly the audio/video), if only for filesize concerns
- Linking to an external file may be a better option
A *Hidden Slide* is one that is still a part of the presentation, and may be viewed in the normal editing mode. However, it will not be considered part of the presentation during Slide Show mode.

- Slides may be hidden because they might only be part of certain versions of the presentation
- They may be hidden because it isn’t likely that topic will come up
- Even when hidden, a slide can still be reached when an appropriate action is added to an element (acting like a navigation button)
The Notes below each slide may be used as a reminder to yourself of what you should be covering.

- Remember: You shouldn’t be simply dumping your speech/presentation onto the slides!

Notes can also be handy for distributing handouts for presentations, as well as for Presenter view (covered next).
Presenter View

*Presenter view* is a special *dual monitor* setup that displays the slides on one screen, and the notes on the other.

- If one of those screens is actually a projector, that means you can see your cue cards, while the audience can see your slides

As a related topic, note that PowerPoint lets you set your presentation resolution. This can let you match up with whatever’s appropriate for your projector’s *native resolution*
Handouts

There are different options for creating handouts in PowerPoint. The two most helpful are:

- Choosing to include multiple slides per page, possibly with blank lines (so students may fill in notes, or the audience may jot down questions) beside them. This is in the Print dialog.
- Using the Save & Send dialog to create a Word document with the features you want.
Custom Slide Show

Suppose you have two versions of a presentation: One that’s expected to take 30 minutes, and one that’s shortened down to 20. You could simply split off into two separate files, but that means that you’d have to update both whenever you wanted to make changes.

- A Custom Slide Show lets you specify an alternate sequence of slides (possibly including only a few of them, and potentially in a different sequence)
- When you’re doing the full 30-minute version, just start it up like normal
- When you need to do the abridged version, play the custom show
Set Up Slide Show

The default presentation options can be changed via the *Set Up Slide Show* button.

It’s simply used for things like controlling whether or not it loops, should be shown in a window, custom shows, etc.
Rehearse Timings

Remember that we said slides could be advanced automatically after specified lengths of time. However, how do we ascertain the best timings? It can be hard to guesstimate that sort of thing for each slide individually.

- The *Rehearse Timings* button (on the Slide Show tab) lets you record your pacing when giving your presentation.
- If you accept the timings, then the next time you present, it will automatically advance whenever you manually advanced during the rehearsal.
- Note that you can choose to deactivate the timings by unchecking the *Use Timings* option.
Recording Presentations

If you wish to save your presentation (for later review, or distribution), you have the option of doing so.

- It will save the slide view of the presentation, and also record from your microphone
- Technically, it’s just setting your timings and embedding audio into your presentation
- The next time you go to the normal Slide Show mode, it will play everything back for you
- Under the File tab, for the Send & Share dialog, you can choose to Create a Video
Broadcasting

If your audience isn’t in the same room, you can broadcast your presentation, viewable to anyone with a reasonably modern web browser.

- If your institution is suitably configured, you can broadcast to a local server
- Otherwise, you can simply broadcast publicly using a Windows Live login, and will receive a unique URL to give everyone who might wish to observe
- Significant Limitation: There’s no audio. You’re expected to be in a conference call
Commenting

Comments are the same as in Word and Excel.

- They’re a thing
PowerPoint Viewer

As a reminder, you may require PowerPoint to create .ppt and .pptx files, but not to view them!

The PowerPoint viewer is a free download.
Other Options

Of course, there are other options to PowerPoint.

- OpenOffice/LibreOffice
- Google’s version
- Beamer
- And there are plenty more web-based ones

Just realize that other choices might not have the same set of features.
Questions

Questions?