APPLIED COMPUTING 1P01

Fluency with Technology

Spreadsheets

APCO/IASC 1P01

Brock University
Spreadsheets

- Spreadsheets are used for arranging, manipulating, and performing calculations on data
- They can be used for presentation, extrapolation, and analysis
- We can combine text, numbers, and graphics
We have some data, that we wish to organize into a logical fashion.

- We place that data into individual spaces called *cells*.
- Cells are aligned into, and referenced according to, *rows* and *columns*.
- We can see the boundaries of individual cells because of the *gridlines*.
  - By default, gridlines are not included when printing.
### Common Screen Elements

#### Comparison of Common Social Creatures

<table>
<thead>
<tr>
<th></th>
<th>Weight</th>
<th>Height</th>
<th># of Legs</th>
<th>Cuteness</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pirates</td>
<td>200&quot;</td>
<td>73&quot;</td>
<td>1</td>
<td>0.0</td>
</tr>
<tr>
<td>Humans</td>
<td>180&quot;</td>
<td>70&quot;</td>
<td>2</td>
<td>2.0</td>
</tr>
<tr>
<td>Ferrets</td>
<td>1&quot;</td>
<td>3&quot;</td>
<td>3</td>
<td>9.5</td>
</tr>
<tr>
<td>Tables</td>
<td>45&quot;</td>
<td>36&quot;</td>
<td>4</td>
<td>3.0</td>
</tr>
</tbody>
</table>
Entering Information

- You can select a cell with either the mouse or the keyboard (cursor keys)
  - Note that there will be certain conditions where you may not be able to immediately change the selected cell
  - e.g. During data entry/formula editing
- If text is too long to fit in a cell, it spills over into the adjacent cell
  - If there’s data in that adjacent cell, then it will block out the former data
  - You can manually add a line break by pressing Alt+Enter (Command+Option+Enter in OSX)
  - You can use Wrap Text (Home → Alignment → WrapText)
  - You can resize the column (automatically, or through various manual methods)
- If you wish to change information, you can type a new version to replace the old one, or edit the existing value/formula in the formula bar
Let’s take a look at the toolbar, shall we?

- Note that some additional context-specific tabs may appear in certain circumstances
  - e.g. Design, Layout, and Format tabs may all appear under Chart Tools when a chart is selected

- Some categories in the tool ribbon will have additional dialogs; some won’t
Types of Data

When entering information, you’re only adding text. However, that text will then be interpreted as one of several types of data.

- e.g. Numbers are appropriate for mathematical operations
- Text is good for simply displaying... text-y word-dealies
- Formulas (we’ll get to these in a bit) are (potentially complicated) sets of instructions, but display as a simple data type
  - You could enter an equation to calculate your final average in a course, but it would appear to be a number/percentage
Formatting Data

There are two basic ways to format a cell’s contents in Excel:

- Traditional text/element formatting (cosmetic details like colour, font, background, etc.)
  - We’ll revisit this with *Styles*

- *Number Formats* to change the representation of data

Let’s take a closer look at those data formats and representation...
Number Formats

Consider what 0.5 could mean, and how it could be represented...

- One half?
- 0.500?
- 50%?
- Basically 1 (rounding)? Basically 0 (truncation)?

We can apply different formats to separate the data from the presentation

- Let's look at fractions, and try out other values
- Ooh, ooh, let's try 1/10! 9/10?
- (If anything neat happened, why?)
Custom Formats

All of the formats follow a deterministic pattern

- That is, there’s a clearly-defined pattern being applied to render the displayed values

If we wished, we could define new custom formats

- This isn’t *usually* necessary, as all of the common uses are already covered

- The official documentation is great for helping with this, but you can also always just apply a format, go to the custom format display, and see how that format was created!
Borders and Shading

Remember how we said that gridlines aren’t normally printed?

- We *can* change that if we want
  
  *(PageLayout → SheetOptions → Gridlines)*, but that would print *all* gridlines!

- As an alternative, we can simply select individual cells (or ranges of cells) to format
  
  - This allows us to not only add lines (of varying thicknesses and patterns), but also to change the background

- If you’re going to be doing this quite a bit, you may want to look into *tables* or *styles* (both of which we’re covering later)
Making Things Fit

- Excel arranges everything into neat, uniform cells
  - Our information might not always want to be that orderly!
- The Home tab has several tools to let us alter the flow a bit
  - The Cells → Format entry can let us change row and column sizing
  - The Alignment group gives us control over everything from rotation to merging
    - Merging cells does what it sounds like; it combines them
    - There’s even a Merge & Center that combines cells and horizontally centres the contents (Useful for combining several cells into a single Title/Heading)
You may have received information in a particular sequence, but want to make use of it in another sequence

- e.g. A randomly-arranged list of names
  - Perhaps it would be nice to alphabetize them?
- How would we handle records that span multiple columns?
- How would we handle sorting based on more than one criterion?
Indexing Cells

I promised we’d do some mathy stuff. However, in order to perform mathematical operations (or make decisions) upon data, we first have to be able to *access that data*

- The simplest way to identify the position (i.e. to *index* a cell is according to its column and row identifiers
- Notice the letters across the top of the worksheet indicating column index, and the numbers down the left side indicating row index
  - A cell’s index is defined as **ColumnRow**
    - e.g. the cell in the third row and second column is **B3**
- We can define a *range* of cells according to its start and end points
  - e.g. a $3 \times 3$ block in the upper-left corner is **A1:C3**
  - We’ll come back to this in a moment
Basic Math

- To indicate that we wish Excel to display the *result* of some operation, rather than to simply display what we type, we start an entry with =
- We can then use typical mathematical operators, and as many numbers as we need to include.

Of course, if we wanted to simply provide all of the data directly to the cell, it’d be pointless to enter it as a formula:
- We would just calculate it once and then enter the result.
- But what if we wanted our answer to depend on the contents of another cell...
A cell reference is what it sounds like: A means of referencing the contents of a cell

- All we need to do is to combine what we’ve learned about entering math with what we know about cell indexing
- e.g. \( =B3+C5+A2 \) will display the result of adding the values in B3, C5, and A2
- It seems easy, right?
  - Actually, *for the most part*, it is!
Reproducing work

Suppose I wanted the numbers 1, 2, 3...98, 99, 100

- I could type each of them out, one by one
  - I also could smash my hand repeatedly with a hammer
    - (I advise against both actions)
- Let’s see what happens when I start typing a few of the digits and fiddle with it a bit...
  - That little grab point’s there... what if I were to drag it?
  - Excel can extend a series if it’s simple enough to identify
- What happens when we try to extend a series of cell references?
  - Hmm... interesting, isn’t it?
  - For that matter, we can get the same effect by simply using Copy & Paste...
  - This brings up our next topic: Absolute vs Relative Cell References
Absolute vs Relative Cell References

- An *absolute* index is one that’s always the same, no matter what
  - Indicated with a $\$
  - Extending a series won’t increment the index
    - Neither will pasting to a new location
- A *relative* index is the kind we’ve seen so far
  - It’s more flexible, so it’s the default
- Note that you can mix & match
  - $A2$ refers to a value that *must* be in column A, but it can be extended across additional rows
  - D$5$ can only be used to reference the $5^{th}$ row, but can reference other columns
Basic Formulas

This is a good time to point out that, as you change data, calculations are always automatically recalculated.

- If you need to, you can also force it from the Formulas tab, or simply hit F9.

Let’s try a bit of basic math, shall we?
Functions

If we wanted, with what we’ve learned, we could write a formula to calculate the average of a range of values, right?

- But that seems like the sort of task that’d be pretty common...
- Excel is supposed to make common tasks easier...
- It seems like it’d have something built-in to handle that for me...

Of course, it does: The function, AVERAGE

- *Functions* are tools (actually sequences of well-defined instructions that have some value to return) that can be invoked via a single word to take care of commonly-used tasks
- Note that function names are *not* case sensitive
  - You want to say aVeRaGe? Go ahead!
Functions
Common and Handy Functions

- average
- median
- mode
- countif
- min
- max
- There’s also standard deviation, etc, but we can’t cover them all
  - There’s a button beside the formula bar that brings up a dialog of functions, which can be filtered according to category
- Note that you may need more complicated ranges than we’ve discussed thus far
  - You can also select disjoint groups by using , (a comma), or by holding $Ctrl$ when using the mouse
Copy and Paste (Special)

Note that, because we’re dealing with overlapping information in the same spaces — Formatting, Formulas, Displayed values, etc. — a basic copy & paste isn’t always enough. We actually have different ones available

- A particularly handy one can be pasting a value
  - For reference, try generating random values
    - Every time you make a change to the page, they’ll be rerandomized
    - By copying and pasting the values, you can fix them into actual numbers
Commenting

Oftentimes, we may worry about whether or not the use of something is clear (particularly when sharing the workbook with another person)

- A *comment* can be added to a cell to include a note
- Let’s revisit the *Review* tab and take a look?
Named Cells

As lovely as $H17$ is, that might not make it easy to remember for the sake of formulas

- The Name Box (which normally shows Cell Indices) can be used to assign a name
- Names may be managed on the Formulas tab (under Defined Names)
- Also, let’s talk about scope for a bit...
Using Multiple Worksheets

Suppose you want more information than should reasonably fit onto a single page

- You *could* simply use a new file...
- But, hey, what was all of that *Sheet1*, *Sheet2*, *Sheet3* stuff at the bottom?
- Note that you can rename sheets!
Referencing across worksheets

Similarly to how you can access the information in another cell, you can also access information in a cell from another worksheet:

- Simply use the worksheet’s name, followed by an exclamation mark and the cell reference.
- If the worksheet’s name includes a space, make sure you surround its name with single-quotes.
- Let’s take a look, shall we?
Hiding Rows/Columns

Sometimes you may want to have space for data, but it doesn’t belong with presented material:

- You can easily hide rows and/or columns
- This can be handy for storing intermediate values in complicated calculations
- Note that this does *not* change any indices that follow it!
- You can still access that data via cell references
- Hidden data, by default, is not included in charts (though you can change that)
Numbers or “Numbers”? 

This is as good of a spot as any to differentiate between numbers and number-like text

- You can, of course, format numbers as text
- Sometimes numbers may be imported as text
  - Typically only a problem when reading from odd imported data sources
  - Excel should warn you that numbers aren’t being treated number-ly, so it shouldn’t be a huge deal
Extending Series

An additional note

In addition to what we’ve already seen, Excel can do some fancy things with series.

- You can play with this via the Fill entry in Home → Editing
- Also, instead of dragging the grab point, try right-dragging it
While we’re at it...

This is a good time to point out the difference between:

- Selecting
- Moving
- Extending

The point is: Be careful precisely where the cursor is!
Let’s just go straight to an example, shall we?
Mathematically speaking, if we have multiple points of data, and assume/suspect a correlation with some axis, then we may wish to estimate additional points in between known data points

- Sufficient “in-between” points constitute a line
- This is called *interpolation*

**Important**: Don’t use line charts arbitrarily! Line charts only make sense if you assume that there really are “points in between” that you’re estimating!

- i.e. Only use them to show a trend, or correlation to the X axis
- Examples? Good or bad? Anyone?

Ooh, does anyone know what a *sparkline* is?
Trend Lines

- Trends are simply patterns or tendencies over time (or some other axis/line)
- Oftentimes data is noisy, or there are other natural fluctuations
  - Sometimes we wish to take note of the overall tendency, rather than focus on the jitter
  - e.g. Global temperatures, price of gold, etc.
- Excel can calculate and show trendlines based on data
  - You can find this in the new tabs added when you select a chart
What-If Analysis
Scenario Manager

Suppose you’re thinking that you may or may not pass a course

- You know how much every piece of work is worth
- You know some of your grades so far
- You want to fiddle with those that haven’t yet been set to see what your final grade might be
- Excel is well-suited for this sort of *What-If* scenario, and even has a *Scenario Manager* built into it (under *Data → DataTools → What-IfAnalysis*)
- Let’s take a look?
Have you ever tried printing a worksheet out, hoping it would all fit, just to find out that it *barely* got cut off and split onto a second page?

The *Page Layout* tab has numerous features for both determining and affecting how the data will be split across pages.
Styles

*Styles* are simply collections of different formatting tips, all collected together.

They’re used to quickly format information to fit a commonly-used theme

- e.g. a *header* theme for a heading

Excel comes with a wide range of built-in themes, but also allows you to define your own
Conditional Formatting

Conditional formatting lets you automagically change the formatting of one or more cells, depending on some criterion.

This is particularly handy when you want to make certain pieces of data stand out because of some condition, but don’t actually know which entries qualify.
Filters and Tables are both used for quickly making data more presentable and useable.

This is probably best shown with an example
Extras

Bits & bobs...

- Protection
- Templates
- Exporting to pdf
- Importing CSV
- Tab-delimited text
- Conditional formulas