Applied Computing/Interactive Arts and Science 1P01
Lab 4 — Microsoft PowerPoint continued
This lab finishes off the PowerPoint content. If you had trouble with the last lab, consider this an opportunity to get back
up to speed. If you didn’t have any trouble last time, you may find yourself finishing a bit early; feel free to explore the
software a bit more.
Specifically, this lab covers animations (including motion paths and triggers), and actions/hyperlinks.

Exercise 1
Animations have numerous uses in PowerPoint, but they all follow the same basic premise: based on some trigger
(timing, mouse click, or the activation of another such trigger), the appearance of an element on a slide is changed.
This change could be the transition from being invisible to visible (i.e. appearing), from visible to invisible (i.e.
disappearing), or simply drawing attention (i.e. emphasizing). We’ll briefly look at all three.
Either load up your slides from last week, or simply start a new presentation. To a slide, add some text and a couple of
shapes. The following instructions will assume something like this:

Sometimes, rather than simply bombarding the audience with a wall of facts, it may be more appropriate to introduce
them individually. This is a good use for animations.
Click on the main text area (i.e. the bulleted list), and bring up the Animations tab.
What we want is an Entrance animation. If you have the window small like I do above, click on Add Animation, and
choose one of the Entrance animations. If you’re using it fullscreen, you should be able to simply select one of the green
icons (note: the different animations can be scrolled through via the two arrows on the right. The extra downwards
arrow is for opening up a larger panel for easier browsing).
I’m partial to the Fade Entrance animation, so that’s what I chose.

By default, for a bulleted list, it assumes you want to have them appear bullet-by-bullet, requiring a click (or press of the
space bar) before each appearance. This is actually what we want, so we won’t change that, but we’ll still look at how
we could change it. First, if you toggle the Animation Pane on, you’ll see that it actually created multiple animations (one
for each bullet). You may need to click the double-arrow to expand the animation to see them all. You could change
these here, but, like I said, they’re what we want, so we won’t.
Alternatively, click on the Effect Options button, and note that By Paragraph is the default animation effect, but we
could also choose As One Object or All at Once (neither of those would be different from each other, for this type of
content).
You should also note that the Animation grouping on the tool ribbon has another dialog button (again, the tiny arrow in
the lower-right corner of the group). This lets you do more specific tweaking, but it really isn’t necessary here.
Now, let’s add a shape, picture, or clipart to the slide:

For mine, I obviously chose a light bulb (Insert -> Clip Art, and then I searched for light bulb); pick whatever you like for
yours, though. An oval shape is entirely fine.
For mine, I’d like the light bulb to pulse on the slide, and then remove itself after the last bullet point is displayed
(because clearly my ideas do not warrant light bulbs; not even crummy incandescent ones).
On the Animations tab, I select Pulse, but note the little 4 that appears next to it (while you’re on the Animation tab)!
That means it’ll show the first three bullet points, and then pulse the bulb! I need to change the sequence, and the best
way to do this is via the Animation Pane.
Again, you can toggle the Animation Pane on and off via the button on the Animations Tab.

This confirms what we’d feared: It first animates the text first, and then the bulb. No matter, we can simply drag its
entry up!
That is, place the cursor over the listing for the “Litebulb”, press and hold the left mouse button, and drag upwards until
you see a thick black line appearing over the first animation. That thick line shows where it intends to put the bulb
animation when you release the button (so, release it).

Much better! There’s just one more thing to change before we continue: Currently, it won’t animate until the presenter
clicks the mouse button (or presses space). However, I want it to just start automatically. There are multiple easy ways
to do this. The two easiest are:


In the Animation Pane, click the dropdown at the right edge of the entry, and select Start After Previous



In the Timing group of the Animations pane, click the dropdown that currently says, On Click, and select Start
After Previous

Note: It wouldn’t matter if you’d chosen Start With Previous instead. Since it’s the first animation either way, it doesn’t
really matter if it’s starting before or with nothing.
Fancy Optional Tip: If you were to apply Start With Previous to the grouped animation for the text, the result would be
to make all of the text appear at once (not what we want). However, click the double-arrow to expand the text
animation into all four animations, and then set just the first text entry’s animation to Start With Previous, and you can
have the first bullet point display when the slide displays, but still have the others fade in when prompted. Like I said, it’s
entirely optional.
Now, as mentioned earlier, I want the light bulb to disappear when the last bullet point appears.
Feel free to try figuring this one out for yourself. I’ll be waiting here in case you need some assistance.
…
…
(Didja get it? Great! But just for ha-ha’s, can I still go through it anyways? Thanks!)
Again, we need to select the light bulb, but this time we don’t want to just select a new Animation style, or it may
replace our existing one. Instead, we want to add one. This is easy: Just click Add Animation, and choose an appropriate
Exit animation (again, this assumes you’re keeping PowerPoint large enough for it to show that button; otherwise, you’ll
have to do it manually).
Having it fly away might be amusing, but I still chose the simple Disappear animation. This time, it’s still the last
animation, but we actually want that. However, we don’t want its disappearance to be triggered by another click; rather
we want it to be synchronized with the appearance of the last bullet point. This is easy: simply set its timing to Start
With Previous.
And that’s it! First exercise done! The only portion of this exercise you need show your TA is that you can have
something appear after the slide begins (e.g. what we did with the bullet points).
(Note: you could also play with things like delays and duration, but I’ll leave it up to you to decide if that interests you or
not)

Exercise 2
For this exercise, we’ll be looking at Motion Paths. Note that you do not need to show your TA anything from this
exercise; it’s not a universally important trick, so give it the time you think it deserves.
There are various different situations where you don’t simply want an element to appear, disappear, or display some
effect in-place. Despite the animation, it’s still fundamentally static. This can be particularly noteworthy when you need
to show a progression, flow of information, or other situation where a single location for a shape simply won’t do.
To demonstrate this, I’ll add an, irritating, distracting, flying chimp head. Because of reasons.
First, I added the clip art (searching for chimp). Next on the Animations tab, I scrolled past Entrance, Emphasis, and Exit
animations, to Motion Paths. (Note: it might not be readily obvious that that view even can scroll)

There are two basic approaches I could take:



I could pick the Shapes option, and then under Effect Options I’d pick Square (even though it’s really a rectangle)
I could pick Custom Path and draw out my exact path

Since the precise pattern I want is a rectangle anyway, that’s what I’ll use, but feel free to play with the Custom Path. It
can be quite a bit of fun!

Note that, after a single animation, it displays the box that reflects the path it’ll take when animating. Use the grips to
expand it as necessary.
There are three problems with how it starts by default:
1. It speeds up at the beginning, and slows down at the end; normally that’d be great, but it isn’t what I want this
time
2. It doesn’t start automatically; it doesn’t start flying until I click or press the space bar
3. It only flies about the slide once; chimp faces want to soar endlessly! (Seriously, look it up)
Point 2 is the easiest to resolve, as we addressed this in Exercise 1. Instead of starting On Click, select either of the other
two options.
We’ll address the other two in the same dialog. Click on the dialog arrow (the small arrow at the lower-right corner of
the Animation group, just below the Effect Options button).
The reason for the acceleration/deceleration is the Smooth start/Smooth end. Just drag them both to being 0 sec.
Before you close the dialog, click on the Timing tab, select Repeat, and choose Until End of Slide.
Click OK and try it out!
You should now have a perpetually flying chimp face. Post-secondary education!

Exercise 3
The final task is arguably the most important. Let’s say there’s a slide we think we might need, but only if a clarification
becomes necessary. We might choose to stick that slide at the end of the presentation, and then hide it.
Try adding a slide, with some content, and hiding it. To hide a slide, either right-click it in the panel to the left and
choose Hide Slide, or simply click the Hide Slide button on the Slide Show tab.
You can tell that it’s hidden, because its slide number at the left will have a box crossing it out.

Before we continue, let’s interject with a semi-common problem: Suppose I want to have the right text box appear after
the slide starts. We already know how to do that, right? Just add an Entrance animation. However, what if we only want
it to appear if/when we click on something else? Actually, this is still easy to do.
First, add the Entrance Animation like normal. Then, bring up the dialog (again, the little arrow in the lower-right corner
of the Animation group in the Animations tab). Under the Timing tab, note the Triggers button. Click it.
The default trigger is part of click sequence. This simply means that multiple animations proceed in a defined sequence,
as we’ve already seen in the Animation Pane. Click Start effect on click of, and click the drown-down. You should see
options for everything on the slide. In my example, I have an Oval, so I chose that.
So, what’s the point? When the slide is presented, the text doesn’t show up. And it won’t show up even if I click
somewhere on the slide, or press the space bar. However, I’ve effectively turned that oval into a button: clicking on it
displays the text!
This kind of thing is commonly used when you want a better control over when/if text will appear.
Additionally, it can be made far more complicated/powerful by also adding triggers for Exits.
Even more powerful, you can have multiple Entrances triggered by the same click, so you could have something like:



Click on a green button to make a text box appear, and to turn the button red
In fact, the red button would actually just be a separate shape that appeared over top of the green one



Both the red button and the text could have Exit animations triggered by clicking on the red button

In other words, you could create a toggle that made something appear and disappear. If you’re interested in seeing an
example, feel free to bring it up in class, or request a sample be put on the course webpage.
We now return to our regularly scheduled program…
In any event, we still need to know how to get to this slide from within the presentation, right?
On some other slide, add a shape (or a Picture, or clip art, or whatever you like).

If you don’t remember from class, after adding a basic shape, you can select the Text Box tool and click on the shape to
add text to it.
What we need to do here is to add an Action or Hyperlink to the shape.
Interestingly enough, because of how PowerPoint evolved, there are two functionally identical ways to accomplish this.
On the Insert tab, under Links, there are two buttons: Action and Hyperlink. You could use either of these.
Hyperlink Button:
Click the button, choose Place in This Document, choose the hidden slide (it’ll have (parenthesis) around its slide
number), and click OK.
Action Button:
Click the button, and under Hyperlink to, click the dropdown and select the slide you want. Click OK.
Note that both approaches are effectively identical; I don’t care which you use.
You should also realize that this is a far more powerful ability than may be immediately obvious. For example, if you
were to add such buttons to the Slide Master, then you could add a link into all of the slides to, for example, the first
page, or to a glossary page. It’s not uncommon to have buttons with links like “previous” and “next”.
To demonstrate this exercise, simply show your TA that you can click a shape to go to your hidden slide.

Submission Guidelines
To receive credit for this exercise, simply show your TA that you’ve set an appearance animation after the slide is
displayed, and that you can link to a hidden slide by clicking on a shape.
You don’t have to show that your motion path or trigger work, though these are very useful tricks (especially triggers).

